1. Hugh is (technically) on vacation for the rest of September, travelling to Europe for his son's wedding in England, and to meet up with Rob in La Rochelle, France. He will be checking the forums most days, and providing some support, but his time will be limited, and he will be unable to do any custom coding work. Apologies in advance for any inconvenience.

[BUG/FEATURE] CSV - Import - upload element set to null

Discussion in 'Standard Support' started by jmfavre, Sep 27, 2009.

  1. jmfavre

    jmfavre New Member

    Level: Community
    the problem is related to "upload" elements. The file name is set to NULL during csv import :rolleyes:. It would be much more consistent/practical to import this value because currently it is impossible to export a CSV and then import it without loosing the information about file elements. Yes, obviously in general, one can argue that importing the file name is not enough, and that the file should be copied by hand. But in the current version, one cannot do this because the filenames cannot be imported.
    This problem can be easily tested on the demo web site http://demo.fabrikar.com/administrator/index.php?option=com_fabrik&c=table using the table test-CSV-import-export, exporting it and then importing it: the files are still there (this is ok), but the element "image" is set to empty.

    Any idea for a workaround ?:D
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I'm unable to raise a ticket on this right now, because of a fubar with the Cc we pay the monthly charge to Unfuddle with. Should be resolved by tomorrow.

    Can you please bump this post early next week, and remind me to raise a ticket on it?

    -- hugh
  3. rob

    rob Administrator Staff Member

    Level: Community
    this one should be fixed in the SVN now - the issue was the when inserting the record the fileupload element was checkign the $_FILES array - if nothing was found there it was telling the form model not to insert any data for the file upload element's field

    1 person likes this.
  4. broadkd

    broadkd New Member

    Level: Community
    I am getting this same error. I have updated to svn 3101 and when I export a csv file then import through the table section my image (file upload data) gets lost (NULL).

    Any help?

    I posted a thread not seeing this at http://fabrikar.com/forums/showthread.php?t=15294


  5. rob

    rob Administrator Staff Member

    Level: Community
    I tested this one again, and it works for me - if you can provide a test page where it doesn't work I'll re look at it


Share This Page