1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

[BUG/FEATURE] CSV - Import - upload element set to null

Discussion in 'Standard Support' started by jmfavre, Sep 27, 2009.

  1. jmfavre New Member

    Level: Community
    Hi,
    the problem is related to "upload" elements. The file name is set to NULL during csv import :rolleyes:. It would be much more consistent/practical to import this value because currently it is impossible to export a CSV and then import it without loosing the information about file elements. Yes, obviously in general, one can argue that importing the file name is not enough, and that the file should be copied by hand. But in the current version, one cannot do this because the filenames cannot be imported.
    This problem can be easily tested on the demo web site http://demo.fabrikar.com/administrator/index.php?option=com_fabrik&c=table using the table test-CSV-import-export, exporting it and then importing it: the files are still there (this is ok), but the element "image" is set to empty.

    Any idea for a workaround ?:D
  2. cheesegrits Support Gopher

    Level: Community
    I'm unable to raise a ticket on this right now, because of a fubar with the Cc we pay the monthly charge to Unfuddle with. Should be resolved by tomorrow.

    Can you please bump this post early next week, and remind me to raise a ticket on it?

    -- hugh
  3. rob Administrator

    Level: Community
    this one should be fixed in the SVN now - the issue was the when inserting the record the fileupload element was checkign the $_FILES array - if nothing was found there it was telling the form model not to insert any data for the file upload element's field

    Rob
    1 person likes this.
  4. broadkd New Member

    Level: Community
    I am getting this same error. I have updated to svn 3101 and when I export a csv file then import through the table section my image (file upload data) gets lost (NULL).

    Any help?

    I posted a thread not seeing this at http://fabrikar.com/forums/showthread.php?t=15294

    Thanks,

    Dave
  5. rob Administrator

    Level: Community
    I tested this one again, and it works for me - if you can provide a test page where it doesn't work I'll re look at it

    -Rob

Share This Page