1. The forums have been upgraded to XenForo 1.4. Please post any issues or comments here.
  2. Our hosting provider will be performing some scheduled maintenance and upgrading during the early morning (US time) of Tue 28th July, starting at approx 2am EST, which will require some down time of the server.

Content Plugin Displays Code, Not Email

Discussion in 'Fabrik 2.0 Beta Testing' started by billandre, Feb 27, 2009.

  1. billandre

    billandre New Member

    Level: Standard
    Hi,

    I just downloaded and installed Fabrik 2.0 a few minutes ago so I assume I have the latest version. I imported the sample data and entered some sample data into the Contact Us form. I then created a new article and used the plugin to display

    {fabrik view=form id=2 row=1}

    The name fields and the message field display correctly but instead of the email address, in the email field I get:

    <script language='JavaScript' type='text/javascript'> <!-- var prefix = 'ma' + 'il' + 'to'; var path = 'hr' + 'ef' + '='; var addy85050 = 'bill' + '@'; addy85050 = addy85050 + 'mmmdjs' + '.' + 'com'; document.write( '<a ' + path + '\'' + prefix + ':' + addy85050 + '\'>' ); document.write( addy85050 ); document.write( '<\/a>' ); //-->\n </script> <script language='JavaScript' type='text/javascript'> <!-- document.write( '<span style=\'display: none;\'>' ); //--> </script>This e-mail address is being protected from spambots. You need JavaScript enabled to view it <script language='JavaScript' type='text/javascript'> <!-- document.write( '</' ); document.write( 'span>' ); //--> </script>
     
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Looks like you have email cloaking enabled in Joomla?

    You can either globally disable it, or in your content, before you display the Fabrik form, use this:

    {emailcloaking=off}

    -- hugh
     

Share This Page