1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

Content Plugin Displays Code, Not Email

Discussion in 'Fabrik 2.0 Beta Testing' started by billandre, Feb 27, 2009.

  1. billandre New Member

    Level: Standard
    Hi,

    I just downloaded and installed Fabrik 2.0 a few minutes ago so I assume I have the latest version. I imported the sample data and entered some sample data into the Contact Us form. I then created a new article and used the plugin to display

    {fabrik view=form id=2 row=1}

    The name fields and the message field display correctly but instead of the email address, in the email field I get:

    <script language='JavaScript' type='text/javascript'> <!-- var prefix = 'ma' + 'il' + 'to'; var path = 'hr' + 'ef' + '='; var addy85050 = 'bill' + '@'; addy85050 = addy85050 + 'mmmdjs' + '.' + 'com'; document.write( '<a ' + path + '\'' + prefix + ':' + addy85050 + '\'>' ); document.write( addy85050 ); document.write( '<\/a>' ); //-->\n </script> <script language='JavaScript' type='text/javascript'> <!-- document.write( '<span style=\'display: none;\'>' ); //--> </script>This e-mail address is being protected from spambots. You need JavaScript enabled to view it <script language='JavaScript' type='text/javascript'> <!-- document.write( '</' ); document.write( 'span>' ); //--> </script>
  2. cheesegrits Support Gopher

    Level: Community
    Looks like you have email cloaking enabled in Joomla?

    You can either globally disable it, or in your content, before you display the Fabrik form, use this:

    {emailcloaking=off}

    -- hugh

Share This Page