1. Hugh is (technically) on vacation for the rest of September, travelling to Europe for his son's wedding in England, and to meet up with Rob in La Rochelle, France. He will be checking the forums most days, and providing some support, but his time will be limited, and he will be unable to do any custom coding work. Apologies in advance for any inconvenience.

Databasejoin join el can't join to users table anymore!

Discussion in 'Fabrik 3.x Testing' started by koolaid2, Mar 5, 2012.

  1. koolaid2

    koolaid2 Member

    Level: Community
    The Databasejoin join element can't join to users table anymore.

    I just get "can find" this value when trying to join the databasejoin element to the Joomla users table.

    I nedd to be able to select user from my record.
    Looks like the join to taeble is missing from the sql!
  2. koolaid2

    koolaid2 Member

    Level: Community
    Ok, this is working again. It's releated to the fact that sometimes a Join reference is left in the fabrik join table after a user element has been deleted.

    I'm not shure if the join references are left in the fabrik table always or exactly when this happen. But I have seen leftovers in the Fabrik join table many times and deleting them often solves problems and I'm pretty shure it was the problem here.

    "making a new fabrik admin-table whit the fabrik_joins as data, then changing all the element in the fabik_joins table to be correct databasejoins elements. Then it's easy to see whitch join that has an element/ table or not."

Share This Page