1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Date Time Major BUG

Discussion in 'Community' started by sunnyjey, Jan 11, 2019.

  1. sunnyjey

    sunnyjey Active Member

    Level: Community
    @cheesegrits

    It looks since latest Github update, there is bug in Date_Time stamp function. TIME STAMP is always returns to 00:00 for default.

    How to check ?
    Create a new list with default elements
    Check TIME in date_time after submitting new rows in form, it always show 00:00

    It only changes if you enable select Time Option in backend of date_time and manually select time. Rest of the time it is fixed to 00:00. I believe it should return Current Server Time depending on UTC / Local setting

    I tried multiple times, but same error.

    Even, I am getting following error since latest github update

    http://fabrikar.com/forums/index.ph...eatedate-with-non-standard-form-format.49877/
     
    Last edited: Jan 11, 2019
  2. Skip

    Skip New Member

    Level: Community
    I think the Timestamp element has not worked like people expect it to work for many years.

    Instead, you may have better luck using the Date element: -> Date Formats: -> Always return today's date.

    Always return today's date - Regardless of any other setting the element will always show today's date. Useful when you want to record the date/time that the record was updated.
     
  3. startpoint

    startpoint Active Member

    Level: Community
    Try with this format: Y-m-d h:i:s
    So it works properly, but of course it is a temporary solution.
    I hope a recent solution.
     
  4. sunnyjey

    sunnyjey Active Member

    Level: Community
    Thank you. But the problem is of current Time Stamp when I want to record current time (h:i:s) for readonly date_time element.

    I believe this can be easily solved, if we add one more option:

    Date element: -> Formating & Time: -> Always return current Time. (Yes/No)
     
  5. sunnyjey

    sunnyjey Active Member

    Level: Community
    This worked. But, if I put Y-m-d H:i:s in place of Y-m-d h:i:s, it doesnt. It looks Hour is case sensitive (since latest GithHUB update).
     

Share This Page