Disable Tool Tips

Discussion in 'Professional Support' started by jeanette, May 5, 2012.

  1. jeanette Member

    Level: Community
    Could someone please provide some advice on how to disable tool tips on my lists?

    I am using Joomla 2.5 and Fabrik 3.0.4 with an artisteer template.

    I've updated to the latest Github for the list template, and can't get the right look on IE, Safari and Firefox....the only solution I see ATM is to get rid of the Tool Tips altogether.


  2. troester Well-Known Member

    Level: Standard
    You can add a custom_css.php with
    .floating-tip-wrapper {display:none!important;}
    Maybe you can use this class to add some styling to "re-set" the aristeer settings.
  3. cheesegrits Support Gopher

    Level: Community
    What's the issue in IE with the tooltip styling?

    For me, with IE9, they look exactly like they do in FF and Chrome. That was one of the reasons Rob just rewrote the tooltip code from scratch, so we could have a lot more control over the styling. We had been using an open source generic tooltip library from elsewhere, but it didn't provide the level of control we wanted over styling.

    So we'd like to get your IE / Safari issues identified and resolved in the main template CSS / tips JS code.

    -- hugh
  4. jeanette Member

    Level: Community
    The first two examples are from IE8, the 3rd from Firefox and the 4th Safari

    The forms for IE8 also have some issues, particularly when running through Citrix (for example all the buttons shift to the right instead of the left).

    Prior to updating, there was no problem with how they looked in FF, but it was very difficult for users to add records in IE8, as the tip would cover the button. With the latest github, the IE8 is improved slightly (as the user can get to the button now) but FF and Safari don't look so good.

    Attached Files:

  5. troester Well-Known Member

    Level: Standard
    Can you post a link to your list to check which Aristeer settings are breaking fabrik ones?
  6. rob Administrator

    Level: Community
    those screen shots look like the tip code BEFORE the latest changes I have made to the tip code, could you double/tripple check you have updated from github and as Troester say's post a link to the page.
  7. jeanette Member

    Level: Community
  8. troester Well-Known Member

    Level: Standard
    You should update the complete GitHub files.

    Did you modify the fabrik default template (your nice PDF button)? If yes you should rename the default folder to e.g. my_default (and select this one as list template). The default template will be overriden during update.

Share This Page