Edit, delete and view icons missing on front end list view

Discussion in 'Standard Support' started by ourblok, Sep 14, 2015.

  1. ourblok

    ourblok Caaan do!

    Level: Community
    Hey all! As the subject of this post implies, the "edit", "delete" and "view" icons are not visible on the front end list view. Instead, I'm seeing a the letters "fl" where the view Icon should be, and the edit and delete icons are not showing at all. Any direction you can provide would be greatly appreciated!
    Thanks!!:D
     
  2. troester

    troester Well-Known Member Staff Member

    Level: Standard
    Seems to be an issue with your Jooma template. Fabrik is using Joomla's bootstrap (BS2) as in Joomla's Protostar template.
    View icon is
    <i class="icon-search ">
    with font IcoMoon
     
  3. rob

    rob Administrator Staff Member

    Level: Community
    hi which template were you using?
     
  4. rob

    rob Administrator Staff Member

    Level: Community
    I'm stabbing a guess at purity iii.
    FYI I've just committed a series of changes in github which should improve JLayout rendering.
    I have also created a new project for creating JLayouts for Fabrik / Bootstrap 3 / font awesome.
    https://github.com/Fabrik/bootstrap3-jlayouts
     
  5. ourblok

    ourblok Caaan do!

    Level: Community
    Howdy Yall. Thanks for your responses. We are using JomSocial's Socialize Template. I believe it's built on the T3 Framework.

    Rob, how do I install or apply the changes you've made?
     
  6. rob

    rob Administrator Staff Member

    Level: Community
    hello, as per the repo readme, you would copy the files into /templates/yourtemplate/html/layouts/com_fabrik
     
  7. ourblok

    ourblok Caaan do!

    Level: Community
    Hey, Thanks for the response. However, It's not taking.

    The path for me is should be templates/socialize/html/layouts/com_fabrik

    FYI, layouts/com_fabrik didn't exist so I had to create it. Am I doing something wrong?

    Thanks for your help and patience.
     
  8. rob

    rob Administrator Staff Member

    Level: Community
    You will need to use the latest github fabrik code (I had completely forgotten to mention that they layouts will only work with the latest code from github!)
    Sorry for the confusion.
     
  9. ourblok

    ourblok Caaan do!

    Level: Community
    Okay. Does that mean just reinstall Fabrik or Is there a link to the latest in github?
     
  10. troester

    troester Well-Known Member Staff Member

    Level: Standard
  11. ourblok

    ourblok Caaan do!

    Level: Community
    Finally got around to doing this. Just wanted to let you know that installing the latest from github worked! Thanks!
     
    troester likes this.

Share This Page