1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice
  2. If you update to Joomla 3.9.16, you will have to update Fabrik from the latest GitHub version, to fix a bug introduced in Joomla, which makes it impossible to list front end folder locations in backend JForms. This affects things like template selection.
    Dismiss Notice

Error in tablefilter

Discussion in 'Community' started by mirceat, Jun 11, 2009.

  1. mirceat

    mirceat Member

    Level: Community
    Hello

    Please help me with following problem:

    SVN 1792

    Fatal error: Call to a member function getFieldDescription() on a non-object in C:\Inetpub\wwwroot\components\com_fabrik\models\tablefilter.php on line 385

    Thank you
     
  2. mirceat

    mirceat Member

    Level: Community
    a little help here, please? Now i see that cascading dropdown filters doesn't work either, can't select second field based on first field value

    I did not made any modifications, just update to latest SVN version
     
  3. mirceat

    mirceat Member

    Level: Community
    SVN 1797, still can't filter properly and still cascading dropdown element doesn't display values in second dropdown

    Here is my config:

    3 dropdown filters, all 3 using database join element

    Selecting 1st filter will change label in second filter (randomly)? Reset, then select second filter, now the label from third filter is changed :) Worst part, i don't get any results, just the message i add for "Empty data message" option. (i try with both "Required filter" option enable and disable)

    About cascading dropdown filters: nothing happen after i select first filter (this is for table view). Entering in form, i see only "loading" image, but nothing else happen.
     
  4. rob

    rob Administrator Staff Member

    Level: Community
    we've recently rewritten from the ground up the filter code, so I guess this is an issue to do with those changes. However, I thought that rev 1797 + solved some issues with the database join filter.
    Looking at the cascading filter I see it still needs some work - I'll add a high priority ticket to this thread right now so you can keep track of where we are with fixing the issue

    Rob
     
  5. rob

    rob Administrator Staff Member

    Level: Community
    hi try updating from the SVN - cascading dropdown filters should work now

    Cheers
    Rob
     
  6. mirceat

    mirceat Member

    Level: Community
    Hi Rob

    Cascading dropdown work now, but filter doesn't, i get "No data found" no matter what i try

    Also, when i use "Link to table" option i see all rows, not only the ones i filter
     
  7. mirceat

    mirceat Member

    Level: Community
    Problem became bigger

    SVN 1824

    Many of our intranet users report that cannot filter using dropdown or cascading dropdown, they get "No data found" message. Problem appear in admin also

    Reset option have a problem also, pressing reset will try to reset option but actually no reset was made, on new search user still have old filter applied

    Ex: first filter - Store; second filter: Town

    Using first filter will show "No data found" message. Of course, data exist in table

    Press Reset, page refresh

    Using second filter (Town): still get "No data found" message; i did not select it but first filter use previous selected value.

    Tested in IE6, FF3, Opera 9, Chrome 2
     
  8. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Rob is working on some filtering issues now, I've pointed him at this thread, hope to get this resolved ASAP.

    -- hugh
     
  9. mirceat

    mirceat Member

    Level: Community
    Thank you very much, now we getting closer to corect results, i can filter data

    What's left: now cascading dropdown have some problems:

    ex: one database join and two cascading dropdown: 1 - region; 2 - county; 3- city; filtered data will show desired info but "city" element will lose selection and also, link table will show no records

    Please see attachment to understand what i want to say :)
     

    Attached Files:

  10. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    So the 'telephone in stock' column is a 'related data' link to a joined table, which should have records?

    -- hugh
     
  11. mirceat

    mirceat Member

    Level: Community
    Yes, users should see numbers of telephones in stock for selected store
     
  12. mirceat

    mirceat Member

    Level: Community
    SVN 1832

    Cascading dropdown still not show latest selection

    Using openstreetmap element will result in a blank page when user select "All" in Display Num filter

    Speaking about Display Num filter. It is possible to not show this filter for certain tables? Why i'm asking: one of my table have 15970 rows..if i select "All" i will get error about memory

    Thank you
     
  13. rob

    rob Administrator Staff Member

    Level: Community
    Fpor the display num question can you post that as a separate thread? This helps us organise things and stops issues being lost inside 15 + posts that relate to another issue.

    I'll try to replcate the 2 cascading dropdown issues now

    Rob
     
  14. rob

    rob Administrator Staff Member

    Level: Community
    try updating now, things should be better

    Rob
     
  15. mirceat

    mirceat Member

    Level: Community
    well, cascading dropdown doesn't work at all now :D

    Edit:

    SVN 1846: now last cascading dropdown element doesn't get any value
     
  16. mirceat

    mirceat Member

    Level: Community
    SVN 1850: problem still exist with cascading dropdown filter, i can't get any value from first filter to second and third
     
  17. rob

    rob Administrator Staff Member

    Level: Community
    ack :( that should be fixed in the svn
    Rob
     
  18. Soulseek

    Soulseek New Member

    Level: Community
    Greetings,
    i still get this error, too.
    Fatal error: Call to a member function getElement() on a non-object in /****/components/com_fabrik/models/tablefilter.php on line 239

    at SVN #1853.
     
  19. rob

    rob Administrator Staff Member

    Level: Community
    can you double check that you uploaded all svn files, and if so can youpoint me at the page where this is happening?

    thx
    Rob
     
  20. Soulseek

    Soulseek New Member

    Level: Community
    Yes, i confirm that all files from latest SVN ( #1858 ) are uploaded.
    Unfortunately i can't give you the url in public, but I can send it via PM if you want...
     

Share This Page