1. Important notice about Cloudbleed - if your site uses the Cloudflare CDN, and you intend to follow the Joomla security team's advice to change your site "secret", you MUST READ THIS NOTICE.
  2. Fabrik 3.6 Released Remember to backup and test your backup before proceeding with this update. Please report any problems you might experience with this new version here on the forum. You are safe to upgrade to Joomla! 3.7 and PHP 7.x with this version of Fabrik. View the blog for more details on this release.

Error We are unable to find this record

Discussion in 'Standard Support' started by arcadeicons, May 5, 2017.

  1. arcadeicons

    arcadeicons Member

    Level: Standard
    I've started to get this error at the top of a form when I am trying to edit a record that has two repeat-groups attached to it. The record appears fine and I'm able to edit everything except the repeat player group.

    add_tournament <--- create event
    add_tournament- [add_tournament_199_repeat] <-- this adds judges to my event (Repeating)
    add_tournament- [add_tournament_repeat_guests] <-- this adds players to my event(Repeating)

    I don't seem to be able to add any more players to my event any more, the existing ones are still there, but when I add a 1 or more new players and click save, I get a success message but the player does not get added to the DB

    If I make a new tournament, it lets me add as many judges and repeat guests as I like on the initial creation, but then going back in to edit, I cannot add further players. I can change every other aspect about the record.

    How can I troubleshoot this further?
     
    Last edited: May 5, 2017
  2. arcadeicons

    arcadeicons Member

    Level: Standard
    I've gone through this form top to bottom, unpublished all elements one at a time for both the main form and the repeat groups, removed all repeat groups and nothing seems to help. Every time I try and edit a record from my add_tournament table I always get the error 'Error We are unable to find this record' at the top of the screen yet I can edit/update all aspects of the form except the the add_repeat_guests area - I cannot add/remove any guests.

    I completely removed the add_repeat_guests repeat group, deleted it and deleted all elements assciated with it. Still, trying to edit an existing record gives the same error.

    I am able to create a new record with all options working, including add_repeat_guests on initial post, but once I go back in to edit I get the same issues.

    Currently this makes creating tournaments impossible as admins constantly have to be able to jump back in and add guests prior to an event starting.
     
  3. troester

    troester Well-Known Member Staff Member

    Level: Standard
    Are all id and parent_id elements published and writable (add + edit access, not readonly...)?
     
  4. arcadeicons

    arcadeicons Member

    Level: Standard
    I went through all elements in both groups, they are all set to public and all published. I've rebuilt both repeat groups. I've removed the repeat groups from the form and the error still shows when trying to edit the record. I went through the trash and made sure it was empty for all types, the only odd thing I am seeing is 3 groups in the trash that are not attached to a form that refuse to delete.
     
  5. arcadeicons

    arcadeicons Member

    Level: Standard
    Logging in as a super user, I don't see this error message, but as a registered user I see it for any record I edit (which means all my users do to), so it seems like it is indeed a permissions issue somewhere and not tied directly to the form itself.
     
  6. arcadeicons

    arcadeicons Member

    Level: Standard
    I'm still struggling to find the root of these error messages. They appear for everything I try and edit the record as a registered user. Need some guidance here in how to troubleshoot this.
     
  7. troester

    troester Well-Known Member Staff Member

    Level: Standard
    Do you have access restrictions via list setting (e.g. canEditRow, a prefilter, edit access "or use field"...)?
     
  8. arcadeicons

    arcadeicons Member

    Level: Standard
    I do have permissions set at list levels to make sure registered users cannot delete or view certain records. The odd thing is that I can edit everything I need to in a record even though I get this error warning. Is there any way to get more specific information than 'couldn't find this record' it's vague at best, not really any help.
     
    Last edited: May 20, 2017
  9. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Supporter
    The login I have for you site doesn't work. Can you correct it in your My Sites.

    -- hugh
     
  10. arcadeicons

    arcadeicons Member

    Level: Standard
    I reactivated it, user and pass the same. Thanks.
     
  11. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Supporter
    Nope. I still get

    Username and password do not match or you do not have an account yet.

    I'm copying and pasting directly from your My Sites info.

    Also, is there a record I can test with that won't mess your live data up.

    -- hugh
     
  12. arcadeicons

    arcadeicons Member

    Level: Standard
    Community builder being a pain. Fixed now for super user access. You wont see the error as a super user, only a registered user when you try and edit an existing record. I will PM you login info for a test registered user with data in their account.
     
  13. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Supporter
    Nope, still can't get at the backend. Same problem.

    -- hugh
     
  14. arcadeicons

    arcadeicons Member

    Level: Standard
    Moved this to private conversation
     

Share This Page