1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

Export CSV not working -

Discussion in 'Standard Support' started by lownotes, Feb 22, 2012.

  1. lownotes New Member

    Level: Community
    Hi,
    I'm using J.1.5.25 + Fabrik 2.1

    Trying to Export CSV from the backend table view.

    Popup modal window with options, then push "Export".

    Next window appears to stall and says...

    Export CSV


    Loading
    0 / undefined.
    Saving to

    If I run firebug on the backend I see this.

    missing ) in parenthetical
    (getData:You have an error in your SQL syntax; check the manual that corresponds...


    If I try to export from the front end I get stuck at the same place.
  2. rob Administrator

    Level: Community
    whats the full error? it seems like the export is trying to grab the data and its query is failing.
    Does the table itself render correctly?
    Does export work on other tables?

    thx
    Rob
  3. lownotes New Member

    Level: Community
    strange, now I get a different error from firebug:
    "NetworkError: 500 Internal Server Error - http://cah.weber.edu/administrator/index.php?option=com_fabrik&c=table&view=table&format=csv&tableid=2&task=viewTable&start=0"

    yes, the table renders correctly.
    no, there are no other tables, except for the sample events table. That does not render correclty though.

    Here is the full errror:
    getData:You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' `jos_fabrik_tshirt`.`id` AS `__pk_val` FROM `jos_fabrik_tshirt` LIMIT 0, 100' at line 1 SQL=SELECT SQL_CALC_FOUND_ROWS DISTINCT , `jos_fabrik_tshirt`.`id` AS `__pk_val` FROM `jos_fabrik_tshirt` LIMIT 0, 100


    thanks Rob

    fyi, the table was small so I just copy and pasted from the admin side, so my task it actually done. But would like to know what is going on.
  4. cheesegrits Support Gopher

    Level: Community
    What options did you select from the popup?

    From the error, it looks like you didn't select any fields to export.

    -- hugh
  5. lownotes New Member

    Level: Community
    everything is default to yes. I tried a couple of variations to see if that would work but as far as I can tell, all options are set to yes as default.
  6. rob Administrator

    Level: Community
    Can you check you have the Joomla 'System - mootools upgrade' plugin enabled.
    I think that is the issue

    -Rob
  7. ejw Member

    Level: Community
    hi,

    I did not start the threat but had the same issue with the same message and indeed, activating the mootools upgrade plugin corrected it

    thx Rob!

Share This Page