1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Fabrik 3.1 for Joomla 2.5?

Discussion in 'Community' started by sales2010, Feb 11, 2014.

  1. sales2010

    sales2010 Well-Known Member

    Level: Community
    Hello,

    In the download area and the Github page there is a message saying "For both Joomla 2.5 & Joomla 3". Unfortunately, i tried this option on Joomla 2.5.18 and now i'm locked out of admin area with this message:

    3.1 package:
    Code (Text):
    Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or '$' in /mypath/administrator/components/com_fabrik/classes/25/layout/file.php on line 430
     
    github version:

    Code (Text):
    Parse error: syntax error, unexpected T_STATIC, expecting T_STRING or T_VARIABLE or '$' in /mypath/components/com_fabrik/helpers/html.php on line 2518
     
    Thank you
     
  2. sales2010

    sales2010 Well-Known Member

    Level: Community
    somehow off topic: last year i could post in Standard support forum, what happened meantime?
     
  3. troester

    troester Well-Known Member Staff Member

    Level: Community
    I can't replicate. I just did a fresh J!2.5.18 installation + pkg_fabrik_3.1.zip from Fabrik download.
    Which php version are you running?

    Standard support: maybe your subscription has finished?
     
  4. Sophist

    Sophist Well-Known Member

    Level: Community
    What version of PHP are you running?
     
  5. sales2010

    sales2010 Well-Known Member

    Level: Community
    php 5.2.5 runs on this webserver, i asked the administrator an upgrade to 5.3
     
  6. jfquestiaux

    jfquestiaux Well-Known Member

    Level: Community
    5.2.5 is indeed a little short to run even J! 2.5. Remember that the new requirement for J! 3.3 will be PHP 5.3.10.
     
  7. lcollong

    lcollong FabriKant d'applications web

    Level: Community
    Is the prerequisites page from the wiki still correct ? I'm unclear about the Troester post : "fresh J2.5 install + Fabrik 3.1". Does this version works without a bootstrap template ? As far as I know the standard 2.5 Joomla package does not contain the bootstrap ? does fabrik package include the framework ? Should we add an extension like this one (http://www.perfect-web.co/blog/joomla/62-jquery-bootstrap-in-joomla-25) on a fresh J2.5 in order to make F3.1 working ?

    I'm currently developing sites running J2.5+F3.0 and one running J3.1+F.3.1. Should I upgrade to F3.1 all of them ?

    Thanks
     
  8. Sophist

    Sophist Well-Known Member

    Level: Community
    There was a previous forum thread (you will have to search) in which someone was running F3.1 on J2.5 and they tried a bootstrap extension I suggested and apparently it worked. You should be able to find it in a search.
     
  9. troester

    troester Well-Known Member Staff Member

    Level: Community
    On Joomla2.5 Fabrik3.1 doesn't need a bootstrap Joomla template.

    You'll need bootstrap if you want to use the Fabrik bootstrap templates (which than have to be copied from /tmpl to /tmpl25)

    Upgrade:
    It's the same with me: a lot of sites running with J!2.5/F3.0 (upgraded from J!1.5) with non-bootstrap Joomla and Fabrik templates heavily adapted for the customers.
    But J!2.5 will be finished with the coming J!3.5 (announced for this summer) and Fabrik3.0...

    So I think we have to bite the bullet and do all this template stuff again:(
    New sites I would do with J!3.2/F3.1.
     
  10. lcollong

    lcollong FabriKant d'applications web

    Level: Community
    Thanks to both of you. I'll make a try with the Troester's suggestion : installing F3.1 to J2.5 and use the "old" template from tmpl25. If things goes wrong I'll find the bootstrap extension suggested by Sophist. I'll keep you Inform.

    Agree with you, Troester, regarding the "old sites" evolution. Not a small work....
     

Share This Page