1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

Fabrik plugin reset and hide filters

Discussion in 'Community' started by futuron, Sep 8, 2009.

  1. futuron Member

    Level: Professional
    I noticed that it works perfectly when you load a fabriktable in a content item with the fabrik plugin like this:

    {fabrik view=table id=2 tablename___elementname=3 layout=templatename showfilters=1 resetfilters=1}

    I need the resetfilter=1 because otherwise it remebers the selection of the filter when i go to another page (or came from another one)

    I don't want to show the filters so i set showfilters=0 but then the resetfilter=1 wasn't working anymore.
    It seems that it's not hiding but not loading the filters when you set showfilters=0 (you should rename it to "loadfilters" instead of "showfilters")

    To work around this I set the showfilter=1 but i hide it with css in that template: .fabrikFilterContainer {display:none}

    Now it doesn't show the filter but it's still loaded ;)

Share This Page