1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Form Email Plugin - possible bug in "Email Sent Field"

Discussion in 'Community' started by econveyors, Feb 12, 2019.

  1. econveyors

    econveyors Member

    Level: Community
    I have a form with an "Email Sent Field" selected, but my email is still being sent when this field's value is 1.

    I have some other conditions I'd like to use with the plugin and then I started experiencing the issue with the email still being sent. I ruled out my other conditions as the cause by testing the form without them in place, only the "Email Sent Field" set.

    Just updated to Joomla 3.9.3 today (although I was experiencing the issue before that update) and I'm on Fabrik 3.9.

    Also, where does one go to subscribe these days?

    Thanks!
     
  2. econveyors

    econveyors Member

    Level: Community
    Friendly bump.
     
  3. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    I just tested this feature, with a YesNo element as the 'already sent' field, and it works as expected.

    Out of interest, do you have an ACL's on your 'already sent' element?

    We aren't doing "all you can eat" subscription support any more, as it just isn't economically viable (we'v e been losing money on it for years). We are moving to a "pay as you go" approach. If you need paid support, contact @mediaateam .

    When we get a little time to work on it (we are insanely busy right now), we'll be adding features on this site to enable you to purchase packs of support hours. But till then, it's ad-hoc.

    -- hugh
     
  4. econveyors

    econveyors Member

    Level: Community
    Thanks for the update on the subscriptions for support. I'll keep that in mind.

    I do have ACL set on the "already sent" element. The ACL settings give access to the element on the list view, details view and form edit view only to administrators, although I've got javascript in place to disable the field on form edit. I don't need the element to show on a new form, so it's set to a level of "No One" which is a work-around I saw mentioned elsewhere to achieve having the element published, but not visible in certain circumstances.
     
  5. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    As a test, can you try removing the ACL, and see if the email plugin then behaves as expected?

    -- hugh
     

Share This Page