1. Hugh is now back at work, more or less full time, after a slower than expected recovery from his neck surgery early this month. Obviously we have a backlog of support to clear, and are working as hard as we can to take care of it. If you have an unanswered thread more than 3 days old, please post one (and only one) "bump" on it, to move it in to our "last 3 days" list. If you have an unanswered issue in a forum you no longer have access to due to subscriptions timing out, please use the Contact Us form, and provide us with the URL to the thread.

Guess link type issue

Discussion in 'Community' started by grey666, Jan 20, 2009.

  1. grey666 Member

    Level: Community
    I installed 2.03b a month ago, my email addresses have been working fine, but after applying the most recent patch (yesterday) - I think it was 1033, my links disappeared system wide - in every form.

    I'm using the Guess link type set to Yes.

    Can I find out where this stands? Thank you!
  2. peamak Moderator

    Level: Community
    I know this is probably not going to help very much but it's best to ask : did you try to edit/save all incriminated elements ?
  3. grey666 Member

    Level: Community
    Yes, many times :)

    None of my email addresses are showing up as links now. I've tried guess link on, guess link off, and entering 'mailto:bleh@gmail.com'.

    It should be working with the current svn?


    Edit: If I change the field type to Link, it works... It used to work as a normal field using the Guess Link Type option in the element screen.
  4. rob Administrator

    Level: Community
    hi this was only working in the detailed view, I've now fixed it in the SVN so that the guess link type also works in the table view.

    Cheers
    Rob
  5. jeffhuff New Member

    Level: Community
    I have "Guess link type" set to no and it shows links in table view. Any idea how to disable this?
    I have tried changing the element type from field to text and it does not help.
  6. cheesegrits Support Gopher

    Level: Community
    I can't duplicate this. The "guess link type" correctly turns links on and off in field elements. Are you running a recent nightly build or SVN version?

    What browser are you using?

    -- hugh
  7. jeffhuff New Member

    Level: Community
    I am running firefox 3.5.x totally patched up

    I hare Fabrik 2.0 rc3 installed on Joomla 1.5.14

    The field is one I use for email address'. I have more than one in there just separated by a space. The first one does not show as a link and the second one does.
  8. cheesegrits Support Gopher

    Level: Community
    Is it a recent nightly build of Fabrik, or the original ZIP from the downloads area?

    If it isn't a recent build, try installing the latest. Remember, DO NOT uninstall Fabrik, just run the latest nightly build thru the normal J! component installer.

    -- hugh
  9. cheesegrits Support Gopher

    Level: Community
    FYI, I just tried with two email addresses separated by a space, still doesn't create a link when that option is disabled.

    -- hugh
  10. jeffhuff New Member

    Level: Community
    I tried it with the august 21 nightly build with the same results.
    I also started to get some 404's with this build so I went back to rc3 download.
  11. cheesegrits Support Gopher

    Level: Community
    Can you point me at the page?

    Remember that there have been about 1000 code revisions / bug fixes since the RC3 download, including some major revisions to the filtering/searching ... so it really would be better if we could get you going on the latest SVN.

    Do you run with SEF enabled?

    -- hugh
  12. jeffhuff New Member

    Level: Community
    SEF is enabled.

    I will set you up an account and pm it when I get home from work tonight. I appreciate the help.

    ;D
  13. jeffhuff New Member

    Level: Community
    Cheesegrits,
    Did you get a chance to check out the link I pm'd you?
  14. cheesegrits Support Gopher

    Level: Community
    Yes.

    ::looks sheepish::

    OK, I lied. No. I'll try and dig it up and dust it off.

    -- hugh
  15. cheesegrits Support Gopher

    Level: Community
    OK, did you ever re-install a recent nightly build? If you have issues with that, as I said before, I'd like to get those resolved, so you can be running the most recent code, same-same as I run. Otherwise debugging the issue is more or less impossible.

    Anyway, yes, I see it happening on your site, but I still have no clue what's going on. If you want to promote that test account to super-admin, so I can get in the backend, that'd be useful. And, if you don't already have it, installing exTplorer would be useful, so I can edit some Fabrik files and put debug code in.

    -- hugh
  16. jeffhuff New Member

    Level: Community
    That site is live and I currently have fabrik online even with the display problem.

    I have a test site with the same configuration that I will set up Fabrik so we can play around with it.

    I will send you a link when I get it up and running! ;D

    Thanks for the help

Share This Page