1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Problems after import CSV

Discussion in 'Standard Support' started by marcelf, Jul 10, 2018.

  1. marcelf

    marcelf New Member

    Level: Community
    After I import a csv file, fabrik creates a list and its elements, but when I try add a record, all fields are blocked, I type and nothing appears. So I must edit and save the element, after this the field back to normal.

    Is this a expected behavior or a bug ?

    Thanks,
    Marcel
     
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    It's not the expected behaviour.
    Which element (type) did you have to save?
    Which exact Joomla and Fabrik version? Which Joomla template?

    "fields blocked": do you get any error messages in your browser console?
     
  3. marcelf

    marcelf New Member

    Level: Community
    Hi, thanks for reply.

    I am using protostar - Default Joomla template.
    joomla version 3.8.10 Fabrik version 3.8.1

    I will describe what I did:
    In the /administrator > fabrik > lists > Import CSV
    I imported a csv file with the content below.

    When I clicked in "View data" I got the attached screen: 1-after-import-booklist.png

    So I must click to edit the list and salve. And now appears the Add button: 2-after-save-list.png

    But when I went in the form page, I type and no letters is written: 3-typing-nothing-appears.png

    After I clicked to edit the element and save, the problem was solved for this field and I can fill it in the form:
    4-after-edit-element.png

    So, I must do it to all fields.

    I can provide more information if you need.
    Thanks,
    Marcel

    File: booklist.csv

    id,title,author,format,price
    1,"The Adventures of Duck and Goose","Sir Quackalot",paperback,10.99
    2,"The Return of Duck and Goose","Sir Quackalot",paperback,19.99
    3,"More Fun with Duck and Goose","Sir Quackalot",paperback,12.99
    4,"Duck and Goose on Holiday","Sir Quackalot",paperback,11.99
    5,"The Return of Duck and Goose","Sir Quackalot",hardback,19.99
    6,"The Adventures of Duck and Goose","Sir Quackalot",hardback,18.99
    7,"My Friend is a Duck","A. Parrot",paperback,14.99
    8,"Annotated Notes on the ‘Duck and Goose’ chronicles","Prof Macaw",ebook,8.99
    9,"‘Duck and Goose’ Cheat Sheet for Students","Polly Parrot",ebook,5.99
    10,"‘Duck and Goose’: an allegory for modern times?","Bor Ing",hardback,59.99
     
  4. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    The issue with having to edit and save the list settings one time is known, I'll be fixing it soon.

    However, I can't replicate the issue you see with no data present.

    I pasted your test data into a file and imported it:

    https://www.screencast.com/t/1iogdAoLlIcl

    ... and it worked fine.

    Are you designating 'id' as the primary key when you import?

    -- hugh
     
  5. marcelf

    marcelf New Member

    Level: Community
    "The issue with having to edit and save the list settings one time is known, I'll be fixing it soon."
    I'm glad to hear that

    About the csv I got imported this small dataset, but I have problems with others files:

    Not found problem: cant find the csv file
    http://marcelferrante.com.br/fabrik/csverrors/notfound/
    example: 2139923.csv
    I got the message after map the elements: cantfindfile.png

    Multivalue problem
    http://marcelferrante.com.br/fabrik/csverrors/multivalue/
    example: justre1201e.csv

    To fix this problem, in Import csv page should be add a configuration bellow text delimiter to indicate:
    Multivalue delimiter: ;
    admin interface to add: add-field-import-csv.png

    Thanks,
    Marcel
    --
    Marcel Ferrante Silva
    gtalk: marcelf@gmail.com
    lattes.cnpq.br/6034149800479841
     

Share This Page