1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

Radio Button Bug? in IE

Discussion in 'Community' started by jwwicks, Jul 8, 2010.

  1. jwwicks New Member

    Level: Community
    [Solved] Radio Button Bug? in IE

    Hello All,

    I'm creating a form the Sacramento Sierra Chapter of the Red Cross for their Hometown Heroes luncheon. I have this weird bug in IE that seems to be related to how Fabrik set up labels for radio buttons.
    Code (text):

    [COLOR=#0000ff]<[/COLOR][COLOR=#800000]label[/COLOR][COLOR=#0000ff]>[/COLOR][COLOR=#0000ff]<[/COLOR][COLOR=#800000]input [/COLOR][COLOR=#ff0000]class[/COLOR][COLOR=#0000ff]='fabrikinput' [/COLOR][COLOR=#ff0000]type[/COLOR][COLOR=#0000ff]="radio" [/COLOR][COLOR=#ff0000]name[/COLOR][COLOR=#0000ff]="fbk_hometown_heros_registration___payment_type[]" [/COLOR][COLOR=#ff0000]value[/COLOR][COLOR=#0000ff]="credit-card"  />[/COLOR][COLOR=#0000ff]<[/COLOR][COLOR=#800000]span[/COLOR][COLOR=#0000ff]>[/COLOR]Credit Card (complete information below)[COLOR=#0000ff]</[/COLOR][COLOR=#800000]span[/COLOR][COLOR=#0000ff]>[/COLOR][COLOR=#0000ff]</[/COLOR][COLOR=#800000]label[/COLOR][COLOR=#0000ff]>[/COLOR]
     
    I fixed some previous issues with a function for the form but in Internet Explorer 8 the hide/show functionality only works if you click the text not the radio button itself.

    Here's the form on SacSierra. On the third page if you try to change the payment type to "Credit Card" by clicking the radio button nothing happens. If you click the label two times, not double click, the other fields get exposed. In FireFox this doesn't appear to be a problem. Single clicking gets some really bizarre behavior in IE.

    Is it the wrapped label element? The missing for attribute? Anyone else experienced this...

    I'm using XP for testing with IE8/IE7 and Fabrik RC5

    Thanks,
    Jw

    PS - It's not a conflict between any elements on the live site. I have a pristine development site with a brand spanking new j1.5.18 and only fabrik rc5 installed with the same result using the default milkyway template.

    PSS - [Solved] Changed the action from Change to Click. Bug noted here.

Share This Page