1. We suggest you do NOT update to Joomla 3.8.10 until we can resolve an issue it causes with caching in Fabrik. If you do install it, you'll need to disable Joomla's "System Cache" in the global System settings.
  2. Apologies for the recent server outage, a planned migration by our host provider to a new location turned into a bit of a nightmare.

Repeated Group "Copy Values" only works on some elements.

Discussion in 'Professional Support' started by bggann, Jan 26, 2018.

  1. bggann

    bggann Member

    Level: Professional
    I have a repeated group. I've turned on the feature that when you add a new group, the data from the current group is copied. That helps 'pre-populate' the repeated group when most items are the same (which they are).

    But - it doesn't 'quite' work.

    1) Items that are 'text' or 'field' copy fine.
    2) Items that are dropdowns (database join, time, date, etc). don't copy.

    I'd like all items in the group to pre-populate - not just text or other 'type in' fields.

    Super ideally, I'd like to choose the items to pre-populate.

    Ideas?
    -Bob
     
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    Ah, looks like there was a missing attribute on that "Fabrik link" param in the plugin XML.

    https://github.com/Fabrik/fabrik/commit/ca3f5b9e16e08b37640765d52753ead278382ad0

    Either do a full update, or just tweak that file by hand. I just did a large commit, updating a bunch of the third party libraries we use, you might want to let that update settle a little, shake any bugs out, before doing a full github update. Although if you don't use PDF, you should be OK, the biggest potential for issues is the update of the DOMPDF library.

    -- hugh
     
  3. bggann

    bggann Member

    Level: Professional
    I do use pdf on this site, though not a lot and we may stop.
    I'll let it settle and make the changes myself.

    I'll do that tomorrow and let you know.

    Bob

    PS - just looked at the commit. Ah man - I'd never have found that. Now I don't feel so bad about not finding where to change it.....
     
    Last edited: Jan 29, 2018
  4. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    Oops, looks like I replied on the wrong thread.

    Re the issue in this thread ... yeah, weird, I had a look and it's correctly cloning things like dropdowns, with the correct option selected, but for some reason the display isn't reflecting the values. I'll keep looking ...

    -- hugh
     
  5. bggann

    bggann Member

    Level: Professional
    Interesting....
     
  6. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    Just FYI I haven't forgotten about this, it's in my rotation of ongoing issues i'm working on.

    Still can'r work out wtf is going on with selects though. I'm doing it exactly how I'm supposed to, as far as JS and the DOM is concerned, but the selection just isn't showing (even though if you look at the source, the current option is marked as selected).

    -- hugh
     
  7. Sophist

    Sophist Well-Known Member

    Level: Community
    I have done a lot of work on fixing various repeat group bugs in PR#1939.

    I wasn't specifically targeting the Copy Values setting because I don't user that myself, and I cannot recall exactly what I changed regarding cloning elements though I do recall doing some work relating to cloned dropdowns, but if you have the time you might want to see if this PR helps at all.
     
  8. bggann

    bggann Member

    Level: Professional
    Thanks Hugh - I haven't had time to work on it either. I'll look at the PR you mention Sophist.
     

Share This Page