1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

REV 606: Element Edit Screen Blank

Discussion in 'Fabrik 2.0 Beta Testing' started by mikesimaska, Oct 17, 2008.

Thread Status:
Not open for further replies.
  1. mikesimaska Member

    Level: Standard
    When attempting to edit or add an element, no fields appear in the edit screen.

    Fabrik Rev 606
    Database Version: 5.0.41-community-nt
    Web Server: Apache/2.0.59 (Win32) DAV/2 PHP/5.2.3
    Joomla! Version: Joomla! 1.5.7

    (btw i upgraded to the latest SVN version to fix the bug where forms were not honoring the connection field for external databases (although tables were). If there's a (relatively) stable version which contains that fix could someone point it out. As it is now I can only add elements in the default install 2.0b3 but can only see forms in the last build)
  2. rob Administrator

    Level: Community
    hi

    Cant replicate this issue, if you ftp the SVN files up to your site could you double check that they all got uploaded correctly. Also what version of php are you running?

    Cheers
    Rob
  3. mikesimaska Member

    Level: Standard
    PHP/5.2.3

    I'm working on local server (Uniform 3.5).

    I uninstalled Fabrik. Reinstalled 2.0b3. Copy/Pasted my SVN-Export folder onto the joomla tree.

    Is there any manual stuff I need to do make sure I'm cleaning everything up?
    fabrik_form_sessions table was still sitting my joomla db after uninstalling. i deleted it

    I can also expose server to web if you need access.
  4. mikesimaska Member

    Level: Standard
    Just did an uninstall-reinstall (no sample data / SVN rev 607)

    created new connection to external db
    created new table based on existing table in external db
    fabrik creates table, form, elements ok
    default table view/ form view / updates work ok
    go to elements
    click on an element name
    open editor
    (see screenshot)

    Attached Files:

  5. cheesegrits Support Gopher

    Level: Community
    What is your PHP memory limit set to?

    Does the same thing happen if you use the default site connection?

    -- hugh
  6. mikesimaska Member

    Level: Standard
    Whatever the uniform server defaults it to which is.....

    32M


    Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--with-gd=shared"
    Server API Apache 2.0 Handler
    Virtual Directory Support enabled
    Configuration File (php.ini) Path C:\WINDOWS
    Loaded Configuration File W:\usr\local\php\php.ini
    PHP API 20041225
    PHP Extension 20060613
    Zend Extension 220060519
    Debug Build no
    Thread Safety enabled
    Zend Memory Manager enabled
    IPv6 Support enabled
    Registered PHP Streams php, file, data, http, ftp, compress.zlib
    Registered Stream Socket Transports tcp, udp
    Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, zlib.*


    Configuration
    PHP Core
    Directive Local Value Master Value
    allow_call_time_pass_reference On On
    allow_url_fopen On On
    allow_url_include Off Off
    always_populate_raw_post_data Off Off
    arg_separator.input & &
    arg_separator.output & &
    asp_tags Off Off
    auto_append_file no value no value
    auto_globals_jit On On
    auto_prepend_file no value no value
    browscap no value no value
    default_charset no value no value
    default_mimetype text/html text/html
    define_syslog_variables Off Off
    disable_classes no value no value
    disable_functions no value no value
    display_errors On On
    display_startup_errors Off Off
    doc_root no value no value
    docref_ext no value no value
    docref_root no value no value
    enable_dl On On
    error_append_string no value no value
    error_log logs/logs.log logs/logs.log
    error_prepend_string no value no value
    error_reporting 6135 6135
    expose_php On On
    extension_dir /usr/local/PHP/extensions /usr/local/PHP/extensions
    file_uploads On On
    highlight.bg #FFFFFF #FFFFFF
    highlight.comment #FF8000 #FF8000
    highlight.default #0000BB #0000BB
    highlight.html #000000 #000000
    highlight.keyword #007700 #007700
    highlight.string #DD0000 #DD0000
    html_errors On On
    ignore_repeated_errors Off Off
    ignore_repeated_source Off Off
    ignore_user_abort Off Off
    implicit_flush Off Off
    include_path .;/usr/local/PHP/includes;/usr/local/PHP/pear;/home/admin/www/plugins/pear/PEAR .;/usr/local/PHP/includes;/usr/local/PHP/pear;/home/admin/www/plugins/pear/PEAR
    log_errors On On
    log_errors_max_len 1024 1024
    magic_quotes_gpc On On
    magic_quotes_runtime Off Off
    magic_quotes_sybase Off Off
    mail.force_extra_parameters no value no value
    max_execution_time 300 300
    max_input_nesting_level 64 64
    max_input_time 60 60
    memory_limit 32M 32M
    open_basedir no value no value
    output_buffering no value no value
    output_handler no value no value
    post_max_size 10M 10M
    precision 14 14
    realpath_cache_size 16K 16K
    realpath_cache_ttl 120 120
    register_argc_argv On On
    register_globals On On
    register_long_arrays On On
    report_memleaks On On
    report_zend_debug On On
    safe_mode Off Off
    safe_mode_exec_dir no value no value
    safe_mode_gid Off Off
    safe_mode_include_dir .;/usr/local/PHP/includes;/usr/local/PHP/pear .;/usr/local/PHP/includes;/usr/local/PHP/pear
    sendmail_from me@localhost.com me@localhost.com
    sendmail_path no value no value
    serialize_precision 100 100
    short_open_tag On On
    SMTP localhost localhost
    smtp_port 25 25
    sql.safe_mode Off Off
    track_errors On On
    unserialize_callback_func no value no value
    upload_max_filesize 10M 10M
    upload_tmp_dir /tmp /tmp
    user_dir /www /www
    variables_order EGPCS EGPCS
    xmlrpc_error_number 0 0
    xmlrpc_errors Off Off
    y2k_compliance On On
    zend.ze1_compatibility_mode Off Off
  7. mikesimaska Member

    Level: Standard
    Yes. I "imported" jos_users. Identical behavior.
  8. cheesegrits Support Gopher

    Level: Community
    Hmm, strange.

    We usually recommend 64MB for PHP memory limit with Fabrik. But typically a memory size violation results in a totally blank, or seriously deformed page.

    But lets try upping your PHP memory limit to 64MB anyway, see if that helps.

    Have you checked your httpd error log, see if there's anything useful in there?

    -- hugh
  9. mike.jupp New Member

    Level: Standard
    Disappearing element dialog

    I had the same problem, but closing down the browser (Firefox) completely and restarting seemed to fix it, so I guess it could be a memory problem.
  10. mikesimaska Member

    Level: Standard
    Upped the limit. Restarted server. Error still occurs. Nothing suspicious in httpd logs.
  11. mikesimaska Member

    Level: Standard
    Restarting firefox did not help. HOWEVER running the page under IE7 *works*.

    BUT I refuse to run IE all the time. Any ideas on how to troubleshoot this firefox / fabrik interaction. Remember: the element dialog works just fine for me with the 2.0b3 version. It's only when I drop in the latest SVN code that I have an issue.


    Update: Opening Firebug and choosing Console | Enable Console for localhost made the behavior disappear. Full dialog now appears.
  12. cheesegrits Support Gopher

    Level: Community
    OK, if you want to set up external access and PM me a backend login, I'll see what I can see. Remember to include a link back to this thread in your PM. If you can also give us an ftp account, that'd help in case we need to upload some debug code.

    Of course, try Mike's suggestion first.

    Also, make absolutely sure you have copied everything from SVN, front end and backend. We did have a bug in a recent SVN rev which caused this, but it was fixed within a few hours. And (although it has nothing to do with this bug) make sure you 'export' your checked-out repo to a clean copy, and use that clean copy for uploading to the server, to avoid having thousands of SVN metadata files in the live site.

    -- hugh
  13. cheesegrits Support Gopher

    Level: Community
    Install the FireBug extension in FireFox, see if you get any JS errors.

    -- hugh
  14. cheesegrits Support Gopher

    Level: Community
    You and me both. And Rob. We're die hard FF folk, and only use IE for JS/CSS compatibility work. Which is what puzzles me about this - we both use FF3 99.9% of the time, and haven't seen this problem.

    You could also try temporarily disabling all your FF extensions, see if that does anything.

    -- hugh
  15. cheesegrits Support Gopher

    Level: Community
    Sorry, only just noticed your edit. Note that editing a post doesn't bump it, so I tend not to notice edits. So always post a separate followup rather than editing posts if you resolve an issue.

    Yes, we do sometimes leave debug code in that uses console.log if it detects FireFox.

    Bad Hugh/Rob. No Donut.

    But glad you resolved it.

    -- hugh
Thread Status:
Not open for further replies.

Share This Page