1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Send email and PDF when submitting a form

Discussion in 'Community' started by RobertG, May 22, 2020.

  1. RobertG

    RobertG Member

    Level: Community
    Hi,

    I have two problems with a very simple test form: a question with text answer, two radio buttons elements, calculation of a score. Data are registered in a table on submit.

    I added a PDF button and a print button to print the form with the answers but have only the labels (standard template bootstrap for pdf). How to print all labels and data?

    I also added an email plugin to the form, to an address "client@mysite.tld" and "send to group" super users: I never receive the emails. I tested with the standard email test (in configuration of Joomla!) and with a contact form: all works fine and I receive the mails. (I'l using PHP mail)
    What can I do wrong?

    I would like to automatically set all labels and data in a PDF and send it to the recipient: is it possible? I didn't find how.

    Thanks for your help.
     
    Last edited: May 22, 2020
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    For sending PDF: enable "Attach as PDF" in Attachments
    http://fabrikar.com/forums/index.php?wiki/email-form-plugin/

    Yes, PDF button in a form doesn't make much sense because it's creating a PDF from the details view (i.e. showing the original form data, not the data just entered but not saved).
     
  3. RobertG

    RobertG Member

    Level: Community
    Thanks troester. I tried with "Attach a PDF" but email is not send so I wanted to test with the button.
    I don't understand why the mail is not sent. :(

    I previously saw this page but can't solve my problem with it.
     
  4. RobertG

    RobertG Member

    Level: Community
    I deleted the email plugin in the form option and added it with only "send to group" super users and it works now: email is sent with PDF. :)
    But I don't understand why it didn't work previously.

    Another question (I abuse): how to display the details after saving the form? Actually after submitting the form is emptied
     
    Last edited: May 22, 2020
  5. troester

    troester Well-Known Member Staff Member

    Level: Community
    On Save it's going back to where it came from (so to an empty form if you have a form menu item, to the list if it was called via the add/edit button etc)
    If you want to go to somewhere else add a redirect form plugin.
     
  6. RobertG

    RobertG Member

    Level: Community
    A menu link opens the form and there is a test menu link to the details of the (empty) form details. Without redirection, it's this page I view after submit.
    If I unpublish this test menu link, the empty form, ready to a new submit, but in the message, I see "Resource not found".
    I have no redirect plugin in the options of that form.
     
  7. RobertG

    RobertG Member

    Level: Community
    It was a cache problem. No more error message.

    To redirect, I don't understand how to display the detail form of the record after saving.
     

Share This Page