• Hello Fabrik Community

    Fabrik is now in the hands of the development team that brought you Fabrik for Joomla 4. We have recently transitioned the Fabrik site over to a new server and are busy trying to clean it up. We have upgraded the site to Joomla 4 and are running the latest version of Fabrik 4. We have also upgraded the Xenforo forum software to the latest version. Many of the widgets you might have been used to on the forum are no longer operational, many abandoned by the developers. We hope to bring back some of the important ones as we have time.

    Exciting times to be sure.

    The Fabrik 4.0 Official release is now available. In addition, the Fabrik codebase is now available in a public repository. See the notices about these in the announcements section

    We wish to shout out a very big Thank You to all of you who have made donations. They have really helped. But we can always use more...wink..wink..

    Also a big Thank You to those of you who have been assisting others in the forum. This takes a very big burden off of us as we work on bugs, the website and the future of Fabrik.

Search results

  1. A

    link forms by province

    The code should be $company = '{$my->id}';
  2. A

    link forms by province

    And don't forget the > , it is $my->id not $my-id
  3. A

    link forms by province

    You should always quote placeholders. So try '{$my->id}'
  4. A

    Fixed Old plugins in github download

    Ooops, had the wrong folder name. Fixed now. Note: the pipeline to update the public repo runs every Monday, Wednesday and Friday early mornings, so recent changes may not get into the public repo until the next run.
  5. A

    pre-check items of form checkbox or picklist

    Try assigning the output of the JHTM to a var of $option. The set $option->selected = 'selected'; (might be 1 or true, don't remember off the top of my head), then $options[] = $option, I am going from old memory here but I hope it helps.
  6. A

    element 'eval populate' echo does not work anymore

    You should also be able to include it via the Web Asset Manager in the eval populate, but I have not tried it.
  7. A

    element 'eval populate' echo does not work anymore

    Echo from eval populate should never have worked. The eval populate must return an array of options. You will need to insert the constant another way. I have used sourcerer to include things like this in the forms intro.
  8. A

    Fixed Old plugins in github download

    You are correct, they should not be there. I will correct.
  9. A

    Advanced search: Error with jdate on IS EMPTY or IS NOT EMPTY

    I think where you first went wrong was in cloning the publicfabrik repo to your bitbucket account, what you want to do is fork it (not clone it) into your account. You can then do sourcetree on the fork and PR from there. Try that and see if it works for you.
  10. A

    Advanced search: Error with jdate on IS EMPTY or IS NOT EMPTY

    The message you are getting makes sense as the source and destination are the same. On my system I also get to select which repo. Is the destination andern beside the waster clickable to allow you to choose a different destination?
  11. A

    Twilio missing in F4

    The Twilo library will be included in the next release. The SMS plugin is not as it has not been tested.
  12. A

    Advanced search: Error with jdate on IS EMPTY or IS NOT EMPTY

    Perhaps it is the way you are creating the pull request. What I have done is to first fork the repo to my own bitbucket account. Then clone it to my local computer where I do the development. Make the changes on my local copy and push the changes to my fork. Note: You may have to do a pull to...
  13. A

    Solved User doesn't show name only ID

    Is ID a dropdown element? Make sure it is a string instead of a number.
  14. A

    Form events are still available?

    Try wrapping it with document.addEventListener("DOMContentLoaded", function(event) { ..... });
  15. A

    Libraries directory

    The library is a separate install within the package. You will need to unzip the package, unzip the library, make your changes, rezip the library and then rezip the package.
  16. A

    Twilio missing in F4

    You can clone the public repo jut like in github and PR any changes. We will review and transfer to the private repo if all is well. Choosing bitbucket was a historical decision way back when we started work on F4. Now it just seems easier to leave it there as we are used to it.
  17. A

    Twilio missing in F4

    @sunnyjey have you tried the SMS plugin with the updated Twilio library? It should still be installed if this is an upgraded site. We can include the Twilio library in the next update but I imagine most people who need it would also want the SMS plugin. p.s. it is likely the Twilio library you...
We are in need of some funding.
More details.

Thank you.

Members online

Back
Top