1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice
  2. If you update to Joomla 3.9.16, you will have to update Fabrik from the latest GitHub version, to fix a bug introduced in Joomla, which makes it impossible to list front end folder locations in backend JForms. This affects things like template selection.
    Dismiss Notice

Fresh install throwing mysql error

Discussion in 'Community' started by thellie, Aug 16, 2019.

  1. thellie

    thellie Member

    Level: Community
    I know this has been an issue in previous years, so I just want to let you know that it's still occurring.

    Having finished the other website, I'm looking to link the articles in that one to another public site. Anyway, trying to install a fresh version of Fabrik is throwing an error every time.

    I've tried installing downloads from Github, from the main download part of the site, from Joomla's 'Install from web'... same each time:

    Code (Text):
    JInstaller: :Install: Error SQL Table 'mirror53_vol_public.#__fabrik_joins' doesn't exist
    Extension Update: SQL error processing query: DB function failed with error number 1146
    Table 'mirror53_vol_public.#__fabrik_joins' doesn't exist
    SQL =
    ALTER TABLE `#__fabrik_joins` CHANGE `table_id` `list_id` INT( 6 ) NOT NULL;
    Package Install: There was an error installing an extension: com_fabrik_3.9.zip
    I'm restoring after each failed version, deleting any fabrik tables that remain in the dbase, but it keeps happening. The site has never had Fabrik installed on it previously.

    I really don't know what else to try.
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Hmmm. Theoretically, those update queries ("ALTER ...") should only happen if you are updating an existing install. Which means that J! thinks you have previously installed an earlier version.

    Check your #__schemas table. Look at #__extensions, find the one with the 'name' of 'com_fabrik', and see if the 'extension_id' for that exists in #__schemas. If so, delete that row in schemas, and try installing again.

    -- hugh
  3. thellie

    thellie Member

    Level: Community
    There are only 3 records in the schema table - referencing joomla, j2xml, and osmap. There are no fabrik records or references to fabrik (via a mysql search LIKE '%fabrik%') in the dbase. This was a new site which I purposely did not install fabrik - this is the public site for general interest, while the fabrik-run admin site is completely separate.

    I'm going to install a fresh joomla site and try to install the github download (that I downloaded yesterday) immediately to see what happens.
  4. thellie

    thellie Member

    Level: Community
    Here's what I did step-by-step, on a new install.
    1. downloaded a new j3.9.11 and installed it
    2. created a .htaccess file (see below for code added)
    3. downloaded a new fabrik github zip file
    4. uploaded to root folder
    5. extracted, then compressed the files/folders inside
    6. move new zip file to root folder, and extracted
    7. went to Discover (there's no 'purge cache' button as per github instructions, so deleted expired cache in joomla system menu)
    8. Hit Discover again - fabrik files showing
    9. In github installation instructions it says "Select the Fabrik package and click the 'Install' icon" - as there is no 'package' record, I tried installing just the fabrik component file alone - comes up with 'source file missing' or similar.
    10. I set number of records to show to ALL. Selected all fabrik records and clicked 'install'. Successfully installed
    11. Turned on all plugins
    12. Went to (successfully installed) fabrik component and clicked on the 'List' menu link
    13. Error message: 1146 Table 'mirror53_fabrik.#__fabrik_packages' doesn't exist
    14. I get an error message for each of the fabrik menu links - either the above one, or #__fabrik_forms, or #__fabrik_connections... doesn't exist
    The only fabrik tables installed are:

    .htaccess file code:
    Code (Text):
    RewriteEngine On
    RewriteCond %{HTTPS} OFF
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

    #RewriteEngine On
    #RewriteCond %{HTTP_HOST} !^www\.
    #RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
    #RewriteCond %{REQUEST_URI} !^/\.well-known/cpanel-dcv/[0-9a-zA-Z_-]+$
    #RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
    #RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/(?:\ Ballot169)?
    #RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

    DirectoryIndex index.html index.php index.shtml home.php
    I must be doing something wrong, but I don't know what :confused:

    You CAN install directly from the github zip file can't you?
  5. troester

    troester Well-Known Member Staff Member

    Level: Community
    Is "fab_" really your Joomla DB prefix i.e. you also have fab_action_logs,... fab_content, ...?

    AFAIK you can't install from GitHub (via discover).
    You should try a new installation (J3.9.11 + Fabrik3.9 via downloads or webinstall), I just tried and both is working fine.
    Then you can add more plugins by downloading and installing via Joomla installer or by doing a full GitHub update (and then discover the ones you need).

    It may be that after you've tried installing the component via GitHub something got mixed up in the DB and then your attempts to do a regular installation via upload or webinstall showed errors.
    Last edited: Aug 18, 2019
  6. thellie

    thellie Member

    Level: Community
    The fab_ was just the quick throw together site to check about the installation, not my production site.

    Can't install from github... okay, I got confused by the word INSTALLATION and its following instructions on the github page...

    I'll give what you have suggested a go, thanks :) ...tomorrow probably - I've been going round in circles all afternoon just trying to get the article metadata to match the #_contents id, but that's another story :confused:
  7. troester

    troester Well-Known Member Staff Member

    Level: Community
    Can you point us the page?
    Some times a WIKI page is not up-to-date.
  8. thellie

    thellie Member

    Level: Community
    Sure Troester,
    It's the github page, not wiki: https://github.com/Fabrik/fabrik

    Scroll down to the readme.md

    To me, a Fabrik user but by no means a PHP, js, or any other coding wizard, or github aficionado, those are installation instructions to get fabrik working inside joomla. Go further down and it has a section on Updating, including "Once you have installed Fabrik 3.x, if you want to stay up to date with the latest code updates between official releases, you can 'update from GitHub'"

    ...but if you can't install from github, then it should be much clearer than this for us
    'easily-confused-coz-we-don't-really-know-what-we're-doing-coz-we-have-to-build-it-all-for-free-and-without-support-or-training' bods.

Share This Page