1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Solved: JS-error at CSV-export

Discussion in 'Community' started by mattsh, Mar 16, 2021.

  1. mattsh

    mattsh Member

    Level: Community
    Hi!

    I need someone pointing me in the correct direction so I can solve this problem.

    Having a js-error when I'm trying to do a csv-export from a list.
    Code (Text):
    500 (Internal Server Error)
    Code (Text):
    Uncaught TypeError: Cannot read property 'err' of undefined
        at Object.onComplete (list.js:3)
        at Object.<anonymous> (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:42)
        at Array.forEach (<anonymous>)
        at Function.forEach (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:5)
        at Array.each (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:9)
        at Object.fireEvent (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:42)
        at Object.e.extend.$owner (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:38)
        at Object.onFailure (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:160)
        at Object.e.extend.$owner (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:38)
        at Object.failure (mootools-core.js?9f458ea91cbac1ebab173e1395e85c09:160)
    Don't know if it make sense...

    Having a test site, which is nearly a copy, but it works without errors at csv-exports.
    And it works fine to do the export from admin but not from front end. Tested different templates.

    Regards
    Matt
    F 3.9.2 (from GitHub last week)
    J 3.9.25
     
    Last edited: Mar 16, 2021
  2. juuser

    juuser Well-Known Member

    Level: Community
    Seeing your other thread, you seem to have something strange going on in your site.

    1) Try with Joomla Protostar template and Fabrik default bootstrap templates, does the error still occur.
    2) Clear Joomla and browser cache.
    3) Make sure you don't have any javascript compressing enabled in your Joomla template settings or some compressing plugin active.
    4) Make sure all the permissions are correct in your server.
    5) Make a full Github update again to be sure all the files are properly copied.
     
    Last edited: Mar 16, 2021
  3. mattsh

    mattsh Member

    Level: Community
    Thanks for answer @juuser.

    1-3 are ok
    4-5 I will do this steps

    Matt
     
  4. mattsh

    mattsh Member

    Level: Community
    Problem solved!
    I found out it was a corrupt file/files somewhere (not template). Maybe Joomla-files, I don't know. So I installed a total new site and the JS-errors are gone.

    Matt
     
    juuser likes this.

Share This Page