Advanced search: Error with jdate on IS EMPTY or IS NOT EMPTY


I would like to change all old date elements from type date to jdate but run into a problem with the Fabrik search.
(I am aware that I can't mix the fields in forms)
I changed the Fabrik element Eingang from date to jdate and didn't change the Fabrik default values of this element.
Then I started an Advanced search on this field:
Advanced search:
Field Eingang IS EMPTY
Field Eingang IS NOT EMPTY

Failed to parse time string ('0000-00-00 00:00:00') at position 0 ('): Unexpected character

All other search parameters like EQUALS etc. work.

The field in the database is configured as:
Type: date
Default: NULL

Do I have to change the database field or the configuration of the Fabrik field?
Okay, thank you. I switched all fields back from jdate to date.

I had a look at the query with fabrikdebug=1. The filter query for date fields checks on the value 0000-00-00 00:00:00. That means the database field has to be type date (of course) and default value should be 0000-00-00 00:00:00 to get correct filter results, right?

Can I change the size of the Advanced search pop-up and the translation?
The window is too small and the German word "grösser" should be "größer" and "IS NOT EMPTY" is not translated at all.

See screenshot ("Erweiterte Suche" = Advanced Search):

Screenshot 2024-03-30 091819.png
Regarding translation: you can always do a language override. In your case for the following language strings:
And regarding the window size I would propose you 'inspect' the window and add the according css values in your custom.css.
Translations/language strings (beside English) are "as they are" at the moment. As @wezetel says you can always override.

But the language file (in this case) is components\com_fabrik\language\de-DE\de-DE.com_fabrik.ini
You could add a pull request on GitHub with the corrected version.

More general

Thank you, I improved the translations for the Drop-Down list, added the translation for the missing string "IS NOT EMPTY" and improved other translations as well in these files:
  • /administrator/components/com_fabrik/language/de-DE/de-DE.com_fabrik.ini
  • /components/com_fabrik/language/de-DE/de-DE.com_fabrik.ini
I would like to add them by pull request. Just to make it clear for me as you wrote "GitHub" and GitHub is mentioned here as well:
You switched the Fabrik source from GitHub to bitbucket, right?
I would have to add a pull request here:
Perhaps it is the way you are creating the pull request. What I have done is to first fork the repo to my own bitbucket account. Then clone it to my local computer where I do the development. Make the changes on my local copy and push the changes to my fork. Note: You may have to do a pull to your local clone from upstream prior to pushing the changes. Then in the fork you can use the three dots menu to the right of the word Clone and select Compare commits branches and tags.

You want the top one to be the fabrikar/publicfabrik and the bottom one to be yourworkspace/publicfabrik. Change the yourworkspace to whatever your workspace name is, then click on Compare. On the resulting page you should see a button to create a PR for the differences.

Give that a try and see how it works for you.
I did it as you described:
I cloned your project into my bitbucket account, installed Sourcetree on my computer, downloaded the fork, edited the language files via Sourcetree and pushed them to my fork. That worked: My bitbucket got updated after I edited the language files.

But I have problems to compare with your repository. I get the message that there are no differences. See Screenshot:

It's a bit confusing that the names master and publicfabrik are the same in your repository. How do I know in the screenshot which is your original and which is mine? When I choose the function "Compare commits, branches or tags" does bitbucket know that I cloned it from yours?
Can I rename my repository from publikfabrik to an individual name or does it have to be identical?

Do you have any idea what I'm doing wrong?
The message you are getting makes sense as the source and destination are the same. On my system I also get to select which repo. Is the destination andern beside the waster clickable to allow you to choose a different destination?
I start here and choose "Compare commits...":

Screenshot 2024-04-12 140521.png

I don't have the option to select a repo. Don't know why.
I leave master and have an option Tag 4.0 that I chosed:

Screenshot 2024-04-12 135003.png

Then I get a result:

Screenshot 2024-04-12 134945.png

I did not click "Mergen" (merge) yet.
Looks better, but is this the solution?

My favorite way to collaborate would be via sourcetree without a clone in bitbucket.
I cloned your repo to my local sourcetree. I get the information that there are new commits since I installed it on 10.4.24
I tried to push my changes via sourcetree but I don't have the rights for it.

Screenshot 2024-04-12 141929.png

When I try to pull the seven new commits I get this error:

Screenshot 2024-04-12 142038.png
I think where you first went wrong was in cloning the publicfabrik repo to your bitbucket account, what you want to do is fork it (not clone it) into your account. You can then do sourcetree on the fork and PR from there. Try that and see if it works for you.