• Payment Plugins Poll

    We need your feedback on the need for updated payment plugins. Please go here and give us your feedback.

  • Joomla 5.1

    For running J!5.1 you must install Fabrik 4.1
    See also Announcements

  • Subscription and download (Fabrik 4.1 for J!4.2+ and J!5.1) are working now

    See Announcement
    Please post subscription questions and issues here

    We have resolved the issue with the J! updater and this will be fixed in the next release.

  • Update & Changlog URL Fixer

    At the present time the update site URL for Fabrik is incorrect in all installations up to and including 4.1. This will be corrected in 4.2, however, if you wish to update Fabrik via the J! Updater you can download and install this plugin.

    This file is installed just like any other extension through the J! Extension Installation panel. It will not however actually install anything. Its sole purpose is to fix the Update Site and Changlog URL's. Once done it will simply exit.

    As always, we recommend you perform a site backup priot to installation.

Fixed Autofill form plugin labels missing in back end

I've just added an autofill plugin to a form and noted that the labels are not displaying correctly in the administrator page (see attachment). It doesn't seem to affect any other form plugins.
I'm using F4.1 and J5.0.3 but it's the same issue on another site with F4.0 and J5.0.3
I haven't found anything in the forum referring to this, although it's not a big problem. Is it just me seeing this?
 

Attachments

  • Screenshot 2024-05-27 170132.png
    Screenshot 2024-05-27 170132.png
    38.3 KB · Views: 25
Ah, yes.
Since ?? J! doesn't accept linebreaks in language files.
Fixed in GitHub.
You can edit plugins\fabrik_form\autofill\language\en-GB\en-GB.plg_fabrik_form_autofill.ini and remove (or replace with <br>) all linebreaks in PLG_FORM_AUTOFILL_ELEMENT_MAP_DESC="..." (line 13 ff)
 
Back
Top