• Payment Plugins Poll

    We need your feedback on the need for updated payment plugins. Please go here and give us your feedback.

  • Joomla 5.1

    For running J!5.1 you must install Fabrik 4.1
    See also Announcements

  • Subscription and download (Fabrik 4.1 for J!4.2+ and J!5.1) are working now

    See Announcement
    Please post subscription questions and issues here

    We have resolved the issue with the J! updater and this will be fixed in the next release.

  • Update & Changlog URL Fixer

    At the present time the update site URL for Fabrik is incorrect in all installations up to and including 4.1. This will be corrected in 4.2, however, if you wish to update Fabrik via the J! Updater you can download and install this plugin.

    This file is installed just like any other extension through the J! Extension Installation panel. It will not however actually install anything. Its sole purpose is to fix the Update Site and Changlog URL's. Once done it will simply exit.

    As always, we recommend you perform a site backup priot to installation.

The auto-complete filter type on the list doesn't work anymore

Hello,

I updated Fabrik to version F4.1 today, and now the auto-complete filter type has stopped working. I had encountered this issue before and resolved it by adding the case 'auto-complete': to the plugins\fabrik_element\user\user.php file after line 902. However, after today's update, the problem has reappeared.

Here are the steps I’ve taken so far:
  1. Cleared the cache multiple times.
  2. Verified that the modification is still in place after the update.
1716832641904.png

Despite these efforts, the auto-complete filter still doesn’t function. Could you provide guidance on how to resolve this issue with the latest update?

Thank you
 
Hmm, it's working on my site.
But it seems you have to type at least 3 characters and you have to type quickly...
 
I think this typing behaviour is a bit strange. But no idea if it was different before.
 
Yes, indeed. It was different before. Typing the first character used to trigger the description of the fields that contained the character.
 
Found it.
It's an option in Fabrik Options JavaScript, default is (and was in F3) 3.
Maybe you had set it to 1 at some point?
 
Thank you. I have set up the Javasc option to 0, and it is working faster. Won’t this set up change the auto-fill behaviour of other forms?
 
Won’t this set up change the auto-fill behaviour of other forms?
I think so, yes. It's general.
But as far as I can see this is as it was always working. autofill-bootstrap.js hasn't changed since years.
I would set Auto-complete minimum to 1, not sure what 0 may do somewhere else.
 
Back
Top