1. Hugh (cheesegrits) here. Thank you for all the good wishes. My back surgery was a success, post-op recovery is going well, and I'm getting stronger and feeling better every day. I hope to be getting back in the saddle and working support again over the next few days.
  2. IMPORTANT NOTE - we have made some changes in our github branch naming. The 'master' branch no longer exists, and is now called 'joomla25' (which is Fabrik 3.0). The 'joomla3' branch (which is Fabrik 3.2) remains unchanged. We have also removed all the other testing branches which had accuulated over the last few years. I have posted a thread in the Community forum for 3.0 with some more information, feel free to as questions there.

Database Join Element Selections not reflected on edit

Discussion in 'Fabrik 3.x Testing' started by bensbenz, May 6, 2012.

  1. bensbenz New Member

    Level: Community
    I setup a form with three groups, one of which has databasejoin multi select element. When I make the selections and click save the proper choices are saved in the database, but they are not selected in the box anymore. So when editing the record I have no idea which items were already selected and I have to re-select the items. This then duplicates things in the database and also leads to a bunch of empty records in the table. When I disable the saving of multipage forms and just use the submit button, everything saves and then repopulates like it should. I have to say, from playing with this saving of partially done forms over the past day, everything seems super buggy, lots of screen flashes as you go between pages, strange loading issues and this. They all seem JS related, is this function running stable for anyone else?

    I am using git v3.0.5-207-g2e34d62, ajax validation and have Save partially completed multi-page forms set to: only logged in users.
  2. felixkat Senior Member

    Level: Community
  3. troester Well-Known Member

    Level: Standard
    I'm not sure if the "Save partially completed multi-page forms" is working.

    I've tried to set up a test form but I get e.g. "Some parts of your form..." error message when I come back (no validation set at all)

  4. rob Administrator

    Level: Community
    i've spent some time today working on save partially completed forms as you were correct they were not working correctly. When you have a moment could you update and test please?
  5. panca New Member

    Level: Community
    I use fabrik 3.0.7 and joomla 2.5.7.
    My problem :
    - when I join with other table and when I edit joined table the value in element form not shown ???

    is there fix for this problem??
  6. rob Administrator

    Level: Community
    you would need to be more precise in your explanation, giving an example URL for example and screen shots of what you set up is for us to help you
  7. panca New Member

    Level: Community
    Now it's worked

    Now it's worked, i use internal id plugin. when joined table.
    Not sure but I think Table must have internal id plugin to work properly.
    Even you create table in Mysql query or phpMyAdmin.
  8. bichu10 New Member

    Level: Community
    Fabrik 3 table join issue

    Am using joomla 2.5.7 with fabrik 3.0.7 updated today. However i face the issue with 3.0.6 as well .
    When i join 2 tables under element section of the join group[ group get created once after join] shows only the sub tables field , on top of this the field property change as well[ please see the attachment]
    Secondly when i check the mySql table of the main table infact all the fields of main table as well as the sub table listed .
    any help will be much appreciated.

    Attached Files:

    • 1.JPG
      1.JPG
      File size:
      74.3 KB
      Views:
      46
    • 2.JPG
      2.JPG
      File size:
      67.7 KB
      Views:
      43
    • 3.JPG
      3.JPG
      File size:
      74.1 KB
      Views:
      41

Share This Page