• Payment Plugins Poll

    We need your feedback on the need for updated payment plugins. Please go here and give us your feedback.

  • Joomla 5.1

    For running J!5.1 you must install Fabrik 4.1
    See also Announcements

  • Subscription and download (Fabrik 4.1 for J!4.2+ and J!5.1) are working now

    See Announcement
    Please post subscription questions and issues here

    We have resolved the issue with the J! updater and this will be fixed in the next release.

  • Update & Changlog URL Fixer

    At the present time the update site URL for Fabrik is incorrect in all installations up to and including 4.1. This will be corrected in 4.2, however, if you wish to update Fabrik via the J! Updater you can download and install this plugin.

    This file is installed just like any other extension through the J! Extension Installation panel. It will not however actually install anything. Its sole purpose is to fix the Update Site and Changlog URL's. Once done it will simply exit.

    As always, we recommend you perform a site backup priot to installation.

Date plugin date picker popup error in J5

sakyildiz

Member
Date plugin's date picker popup does not display correctly in J5. Browser's console says it is related with tinymce.min.js
 
I can confirm the display issue, but I can't confirm this is depending on tinymce.min.js (took me some time to clone my development site and do the upgrade to J5).
Nonetheless this could be solved with some (custom) css-statements. I'll come back, when I have discovered in detail, what is needed.
 
Just found out: obviously the J5 upgrade deleted some files in the media/system/css folder where calendar-jos.min.css was located. I copied the file to the mentioned folder and it works.
Probably some other problems will occur :-(
 
Hey,

I have a fresh J5.0.2 installation and Fabrik 4. Unfortunately the Date picker doesn't work at all. I see the icon but it doesn't Pop up when I click on it.

Thx for any help
 
Hi,

yes, Fabrik 4.0 (01.02.2024)
Frontend and Backend
Form and List. Default Filter setup.
 
Hey, indeed the browser console shows the following:

Fabrik form::addElements: Cannot add element "ajs_user_profile___passport_expiry_date" of type "FbDateTime" because: Calendar is not a constructor
 
I can't replicate. With F4.0 the old date element is working everywhere on my J!5.0.2 site.
 
I should have read the important bits and pieces while setting up the date field. I still had a jdate element active and this caused the date picker not to work.

thanks for all your time wasted to help a stupid beginner
 
Back
Top