1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Error in List Advanced Search using date value

Discussion in 'Community' started by cheyennemtnman, Apr 21, 2021.

  1. cheyennemtnman

    cheyennemtnman Member

    Level: Community
    Had a person doing data entry via a form... went to check entry for an error... used list view and tried to use advanced search to filter the list by placing a date in mm-dd-yr (10-24-19) format and caused this error...
    ErrorwhenenteringdatevalueinAdvanceSearchoptionas10-21-19.png
    I instructed her to clear the cache in Chrome with CTRL + Shift + Del combination and that did not clear the problem.

    The list menu item shows the same error when selecting it on the menu... it is like the advance Search filter is stuck.

    Clearing the cache does not clear it. I replicated it on my PC and found the same error...
    and could not clear it. I went to Edge and I was able to access the list with no problems. But if I enter a date manually (date picker seems to be disabled) mm-dd-yy , the error occurs again. But... I can clear the error by CTRL + Shift + Del in Edge... then select list and it behaves as expected. Only in Chrome does it remain stuck when accessing the list from the menu.

    I went to the backend and tried to clear the filter it seemed like the clear went through but when I clicked on Advanced Search in backend View Data of list... I get the popup and it says loading but nothing loads.
    Message Filtered Cleared.png BackendAdvanceSearchHangsatloading.png
    Nothing happens.. just the loading box until I "X" it

    Is there something I am missing to clear Chrome of the listing advanced search settings?
     
  2. cheyennemtnman

    cheyennemtnman Member

    Level: Community
    I rebooted the PC so that cleared the problem... Just curious why this error occurs and can not be cleared in Chrome.
     
  3. juuser

    juuser Well-Known Member

    Level: Community
    With jdate, there is a known bug that the calendar does not open in advanced search. And also manually added date in format of mm-dd-yyyy does not work and causes the error above. dd-mm-yyyy and dd.mm.yyyy seem to be working.

    About the cache, there's a faulty date filter applied to list so it's not displaying. Just add /?resetfilters=1 or &resetfilters=1 (depending whether you have sef url enabled or not) to the url and it should clear the filter and the error.
     
    cheyennemtnman likes this.
  4. cheyennemtnman

    cheyennemtnman Member

    Level: Community
    Thank you! Reset Works! after SEF /?resetfilters=1
    I was trying to understand why I could clear in Edge but not in Chrome.... with the Ctrl+Shift+Del key combination. And how and why it would affect the backend.
     

Share This Page