1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

[solved] Cant download PDF on ios devices

Discussion in 'Standard Support' started by tagger, Feb 1, 2019.

Thread Status:
Not open for further replies.
  1. tagger

    tagger Member

    Level: Standard
    Hi Fabrikants!

    I have a nasty bug, where the PDF download from details page work on Windows and Android, but not on (newer) IOS devices. When button clicked, just a blank page appears. Works on an older Iphone5, though...

    Using a custom template, but same issue using standard bootstrap template (with or without bootstrap css included)

    also tried to force download pdf files per htaccess, but had no luck....

    tried multiple newer iphones / ipads with or without installed adobe reader, tried safari and chrome

    only error message I get is "Lost Connection"

    tried cache/gzip on/off, PHP 7.1 and 7.2

    Anyone an idea?? or can replicate?

    (latest J! and github F (from today))
     
    Last edited: Feb 1, 2019
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Unfrotunately I don't have any iThing devices to test it on.

    -- hugh
     
  3. troester

    troester Well-Known Member Staff Member

    Level: Community
    Just tested on an iPad with Safari (no "newer" device but recent IOS): the PDF is opening in the browser instead of downloading but showing up correctly.
     
    tagger likes this.
  4. tagger

    tagger Member

    Level: Standard
    I could give you remote access to a hackintosh with xcode iphone simulator running....where same error occurs...:)

    but never mind...I try some more things first
     
  5. tagger

    tagger Member

    Level: Standard
    Ok, think I got it solved by activating! compression in my server cpanel...
     
Thread Status:
Not open for further replies.

Share This Page