1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

Crob Job Stop Working

Discussion in 'Professional Support' started by teoyh, Jun 14, 2016.

  1. teoyh

    teoyh Member

    Level: Community
    Hi I had no idea what happen my crob job suddenly stop working.

    I had check, my System - Fabrik Scheduled Tasks is enabled.

    I had also enable require query string to yes

    Cron_Setup.PNG

    In my crob job I had enter the url as https://mysitename.com/index.php?fabrik_cron=1

    If I manually select job and click run it will run but not when I trigger the url

    Is there anything else I can check to get it working

    I am using Fabrik 3.0.x and joomla 3.5.1
     
    Last edited: Jun 14, 2016
  2. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Community
    Are you really running 3.0.x?

    -- hugh
     
  3. teoyh

    teoyh Member

    Level: Community
    In the fabrikcron.php ;

    from line 185 to 189 ;

    $this->query
    ->select("id, plugin, lastrun, unit, frequency, " . $nextRun . " AS nextrun")
    ->from('#__{package}_cron')
    ->where("published = '1'")
    ->where("$nextRun < '" . JFactory::getDate()->toSql() . "'");

    there is a double where in the query statement is this a syntax error ?
     
  4. troester

    troester Well-Known Member Staff Member

    Level: Community
    No, it's like an AND.
    What is your exact Fabrik version?
    With which Fabrik and Joomla version was it running?

    What are you doing in your php code?
    (e.g. J!3.5.1 now is VERY strict about email settings)
     
  5. teoyh

    teoyh Member

    Level: Community
    Fabrik 3.4.3 I did an update last Friday from Git
    Joomla 3.5.1
    The strange thing is the cron job will only run if I change the 2nd where to and.

    I check this file because my cron job is not running :(
     
  6. teoyh

    teoyh Member

    Level: Community
    I think I found the reason why it is not working my Server Time Zone was set to Singapore time and not Universal Time after I switch to Universal Time it start working again.

    Is there anyway to accommodate user setting ?
     
  7. troester

    troester Well-Known Member Staff Member

    Level: Community
    Ah yes, there's a bug in the timezone handling if you are editing your cron job in the backend.
    https://github.com/Fabrik/fabrik/issues/1590

    Set your Joomla time zone back to Singapure.
    But every time you are editing your cron job you must also edit the "Last run" and subtract the timezone offset
    If it's showing 2:00 in the cron list view it will show 10:00 inside the cron job (assuming Singapore is UTC+8?) and you have to change it back to 2:00 before saving.
     
    teoyh likes this.
  8. teoyh

    teoyh Member

    Level: Community
    Cool ...glad that it work many thanks for your help :)
     

Share This Page